Back
Maintenance

DNS migration

Completed 15 Feb at 01:00pm CET.

soap.coffee
Completed

Maintenance completed

Posted 15 Feb at 01:00pm CET.
Started

Migration of DNS for soap.coffee from OVH to Vultr nameservers

Posted 15 Feb at 12:00pm CET.